Migrate global configuration to and expand home

- Move lots of system config to home (browser, editors, etc.)
- Improve catppuccin support (kitty, cursors, etc.)
- Improve overall theme (fonts, icons in kitty)
- Add coded's system hardware configuration ("shorthair")
- Add the ed editor
- Split minion's system hardware configuration ("greylag") into several files
- Improve shell support (aliases, useful packages, replacements, etc.)

Change-Id: Ie6d40f809b2662268a9a6fa8b241641bbfef9442
Reviewed-on: https://git.clicks.codes/c/Chimera/NixFiles/+/383
Tested-by: Skyler Grey <minion@clicks.codes>
Reviewed-by: Samuel Shuert <coded@clicks.codes>
diff --git a/homes/x86_64-linux/minion@greylag/default.nix b/homes/x86_64-linux/minion@greylag/default.nix
index 2496649..c94cebc 100644
--- a/homes/x86_64-linux/minion@greylag/default.nix
+++ b/homes/x86_64-linux/minion@greylag/default.nix
@@ -63,9 +63,18 @@
         reactDevTools.enable = true;
         adnauseam.enable = true;
       };
-      extraExtensions = [
-        config.nur.repos.rycee.firefox-addons.sidebery
-      ];
+      extraExtensions = [ config.nur.repos.rycee.firefox-addons.sidebery ];
     };
+
+    shell.bash.enable = true;
+    shell.defaultAliases.enable = true;
+
+    theme.font.nerdFontGlyphs.enable = true;
+
+    editor.ed.enable = true;
+    editor.neovim.enable = true;
+    editor.emacs.enable = true;
+    editor.neovim.defaultEditor = false;
+    editor.emacs.defaultEditor = false;
   };
 }