Migrate global configuration to and expand home

- Move lots of system config to home (browser, editors, etc.)
- Improve catppuccin support (kitty, cursors, etc.)
- Improve overall theme (fonts, icons in kitty)
- Add coded's system hardware configuration ("shorthair")
- Add the ed editor
- Split minion's system hardware configuration ("greylag") into several files
- Improve shell support (aliases, useful packages, replacements, etc.)

Change-Id: Ie6d40f809b2662268a9a6fa8b241641bbfef9442
Reviewed-on: https://git.clicks.codes/c/Chimera/NixFiles/+/383
Tested-by: Skyler Grey <minion@clicks.codes>
Reviewed-by: Samuel Shuert <coded@clicks.codes>
diff --git a/modules/home/shell/zsh/default.nix b/modules/home/shell/zsh/default.nix
new file mode 100644
index 0000000..6b669fd
--- /dev/null
+++ b/modules/home/shell/zsh/default.nix
@@ -0,0 +1,51 @@
+{
+  config,
+  lib,
+  pkgs,
+  ...
+}:
+{
+
+  options.chimera.shell.zsh = {
+    enable = lib.mkEnableOption "Enable ZSH Shell";
+    default = lib.mkOption {
+      type = lib.types.bool;
+      description = "Set as default shell";
+      default = true;
+    };
+    extraAliases = lib.mkOption {
+      type = lib.attrsOf lib.types.str;
+      description = "Attrset of extra shell aliases";
+      default = { };
+    };
+    dirHashes = lib.mkOption {
+      type = lib.attrsOf lib.types.str;
+      description = "Attrset of ~DIR's";
+      default = { };
+    };
+  };
+
+  config = lib.mkIf config.chimera.shell.zsh.enable {
+    programs.zsh = {
+      enable = true;
+      enableAutosuggestions = true;
+      enableCompletion = true;
+      autocd = true;
+      defaultKeymap = "emacs";
+
+      shellAliases = config.chimera.shell.zsh.extraAliases;
+
+      dirHashes = config.chimera.shell.zsh.dirHashes;
+
+      history = {
+        extended = true;
+      };
+      historySubstringSearch.enable = true;
+
+      oh-my-zsh = {
+        enable = true;
+        plugins = [ "git" ];
+      };
+    };
+  };
+}