feat: add xwayland-satellite

Niri doesn't come with xwayland support, so we provide
xwayland-satellite to have native-like X windows in wayland

There is a bug with this and xwayland 24 which means that steam big
picture mode cannot display. Unfortunately, there is a bug in xwayland
23 which causes some games to be unable to launch

You also need to disable "Enable GPU accelerated rendering in web
views", which thankfully you can do with this patch (as the settings are
not a webview)

Change-Id: I6c1d417e433abda269cfb08b210c55ae688af2b0
Reviewed-on: https://git.clicks.codes/c/Chimera/NixFiles/+/717
Tested-by: Skyler Grey <minion@clicks.codes>
Reviewed-by: Samuel Shuert <coded@clicks.codes>
diff --git a/modules/home/git/default.nix b/modules/home/git/default.nix
index ecbb140..63a12da 100644
--- a/modules/home/git/default.nix
+++ b/modules/home/git/default.nix
@@ -115,12 +115,13 @@
     programs.git = {
       enable = true;
 
-      delta = {
-        enable = config.chimera.git.delta.enable;
-        options.light = lib.mkIf config.chimera.theme.catppuccin.enable (
-          config.chimera.theme.catppuccin.style == "Latte"
-        );
-      };
+      delta = lib.mkIf config.chimera.git.delta.enable (lib.warn "Delta is currently disabled due to the build being broken in upstream nixpkgs" {});
+      # {
+      #   enable = config.chimera.git.delta.enable;
+      #   options.light = lib.mkIf config.chimera.theme.catppuccin.enable (
+      #     config.chimera.theme.catppuccin.style == "Latte"
+      #   );
+      # };
 
       extraConfig = {
         init.defaultBranch = "main";