Fix using emacs as a default editor

Change-Id: Id6489fc5e2b1c0a658eed0376f0891c0fb9fe3d8
Reviewed-on: https://git.clicks.codes/c/Chimera/NixFiles/+/544
Tested-by: Skyler Grey <minion@clicks.codes>
Reviewed-by: Samuel Shuert <coded@clicks.codes>
diff --git a/modules/home/shell/default.nix b/modules/home/shell/default.nix
index 9eb874f..2924d6d 100644
--- a/modules/home/shell/default.nix
+++ b/modules/home/shell/default.nix
@@ -83,7 +83,7 @@
         lib.mkIf (config.chimera.shell.rebuildFlakePath != null)
           "sudo nixos-rebuild switch --flake ${config.chimera.shell.rebuildFlakePath}";
       clr = "clear";
-      edit = config.home.sessionVariables.EDITOR;
+      edit = builtins.toString config.home.sessionVariables.EDITOR;
       find = lib.mkIf config.chimera.shell.replacements.bfs.enable "${pkgs.bfs}/bin/bfs";
       grep = lib.mkIf config.chimera.shell.replacements.ripgrep.enable "${config.programs.ripgrep.package}/bin/rg";
       top = lib.mkIf config.chimera.shell.replacements.htop.enable "${config.programs.htop.package}/bin/htop";