chore: flake update and patch warnings

Change-Id: Ia82219292b1390de93be389da94886d37a7b8461
Reviewed-on: https://git.clicks.codes/c/Chimera/NixFiles/+/885
Tested-by: Samuel Shuert <coded@clicks.codes>
Reviewed-by: Skyler Grey <minion@clicks.codes>
diff --git a/modules/home/wayland/default.nix b/modules/home/wayland/default.nix
index e6b05df..5ad25f6 100644
--- a/modules/home/wayland/default.nix
+++ b/modules/home/wayland/default.nix
@@ -44,6 +44,7 @@
         example = "dvorak";
         default = "";
       };
+      appleMagic = lib.mkEnableOption "Emulate PC keys on Apple Magic Keyboard";
     };
 
     input.keybinds.alternativeSearch.enable = lib.mkEnableOption "Use alt + space or SUPER + D to open search";