chore: flake update and patch warnings
Change-Id: Ia82219292b1390de93be389da94886d37a7b8461
Reviewed-on: https://git.clicks.codes/c/Chimera/NixFiles/+/885
Tested-by: Samuel Shuert <coded@clicks.codes>
Reviewed-by: Skyler Grey <minion@clicks.codes>
diff --git a/modules/home/wayland/hyprland/default.nix b/modules/home/wayland/hyprland/default.nix
index 5dee95f..098a33c 100644
--- a/modules/home/wayland/hyprland/default.nix
+++ b/modules/home/wayland/hyprland/default.nix
@@ -33,7 +33,6 @@
default = [ ];
};
keybinds = {
- appleMagic = lib.mkEnableOption "Emulate PC keys on Apple Magic Keyboard";
volumeStep = lib.mkOption {
type = lib.types.int;
description = "Amount to increase volume by when media keys are pressed in %";
@@ -144,7 +143,7 @@
kb_variant =
lib.mkIf (config.chimera.input.keyboard.variant != null)
config.chimera.input.keyboard.variant;
- kb_options = lib.mkIf (config.chimera.hyprland.keybinds.appleMagic) "apple:alupckeys";
+ kb_options = lib.mkIf (config.chimera.input.keyboard.appleMagic) "apple:alupckeys";
natural_scroll = config.chimera.input.mouse.scrolling.natural;
numlock_by_default = true;