Move the rest of the TODO's into TODO.md

Change-Id: I629370f5503a5850cb2c8724bd58108c1a1dc18f
Reviewed-on: https://git.clicks.codes/c/Chimera/NixFiles/+/425
Reviewed-by: Samuel Shuert <coded@clicks.codes>
Tested-by: Skyler Grey <minion@clicks.codes>
diff --git a/modules/home/git/default.nix b/modules/home/git/default.nix
index b8ac878..95d3f8d 100644
--- a/modules/home/git/default.nix
+++ b/modules/home/git/default.nix
@@ -61,15 +61,7 @@
         core = {
           repositoryformatversion = 0;
           filemode = true;
-          bare = false;
-          logallrefupdates = true;
-          fsmonitor = true;
-          autocrlf = "input";
-          splitIndex = true;
-          untrackedCache = true;
-        };
-        pull = {
-          rebase = "merges"; # TODO: from git docs, should we provide an option for this?: NOTE: this is a possibly dangerous operation; do not use it unless you understand the implications (see git-rebase[1] for details).
+ # TODO: from git docs, should we provide an option for this?: NOTE: this is a possibly dangerous operation; do not use it unless you understand the implications (see git-rebase[1] for details).
         };
         push = {
           autoSetupRemote = true;