Merge with Coded's config

As we're working on similar things, it makes sense to make a single
config with all our stuff together. We've named our coalition "chimera"
as Coded's devices are named after cat breeds and mine are named after
bird species. We'll be using NixOS options to enable us to have
different configurations anywhere we want that

Co-Authored-By: Samuel Shuert <coded@clicks.codes>
Change-Id: Idb102526d84e76edb0bfe7153bd18dfe8566516b
Reviewed-on: https://git.clicks.codes/c/Chimera/NixFiles/+/382
Reviewed-by: Samuel Shuert <coded@clicks.codes>
Tested-by: Skyler Grey <minion@clicks.codes>
diff --git a/flake.nix b/flake.nix
index afc5748..915c0e0 100644
--- a/flake.nix
+++ b/flake.nix
@@ -30,9 +30,12 @@
       url = "github:saimoomedits/eww-widgets";
       flake = false;
     };
+
+    nur.url = "github:nix-community/nur";
   };
 
-  outputs = { self, nixpkgs, ... }@inputs:
+  outputs =
+    { self, nixpkgs, ... }@inputs:
     inputs.snowfall-lib.mkFlake {
       inherit inputs;
       src = ./.;
@@ -44,21 +47,23 @@
       homes.users."minion@greylag".modules = [
         inputs.hyprland.homeManagerModules.default
         inputs.anyrun.homeManagerModules.default
+        inputs.nur.hmModules.nur
       ];
 
       system.modules.nixos = [
         inputs.hyprland.nixosModules.default
+        inputs.nur.nixosModules.nur  
       ];
 
       snowfall = {
-        namespace = "minion";
+        namespace = "chimera";
 
-        meta.name = "minion";
-        meta.title = "Minion's Nix Configurations";
+        meta.name = "chimera";
+        meta.title = "Coded and Minion's Nix Configurations";
       };
 
       outputs-builder = channels: {
-        formatter = nixpkgs.legacyPackages.${channels.nixpkgs.system}.nixfmt;
+        formatter = nixpkgs.legacyPackages.${channels.nixpkgs.system}.nixfmt-rfc-style;
       };
 
       channels-config = {