feat: replace nix with lix

Lix is a fork of cppnix, see https://lix.systems/ for more details

Change-Id: Icfeeeddb85fc2f62d973269e7e669652ceab6a11
Reviewed-on: https://git.clicks.codes/c/Chimera/NixFiles/+/710
Tested-by: Skyler Grey <minion@clicks.codes>
Reviewed-by: Samuel Shuert <coded@clicks.codes>
diff --git a/flake.nix b/flake.nix
index 4b6fc1e..385a9e7 100644
--- a/flake.nix
+++ b/flake.nix
@@ -32,6 +32,15 @@
     };
 
     hyprland.url = "github:hyprwm/Hyprland";
+    lix = {
+      url = "git+https://git@git.lix.systems/lix-project/lix?ref=refs/tags/2.90-beta.1";
+      flake = false;
+    };
+    lix-module = {
+      url = "git+https://git.lix.systems/lix-project/nixos-module";
+      inputs.lix.follows = "lix";
+      inputs.nixpkgs.follows = "nixpkgs";
+    };
 
     nix-index-database = {
       url = "github:nix-community/nix-index-database";
@@ -72,6 +81,7 @@
         inputs.hyprland.nixosModules.default
         inputs.nur.nixosModules.nur
         inputs.sops-nix.nixosModules.sops
+        inputs.lix-module.nixosModules.default
       ];
 
       systems.hosts.greylag.modules = [