feat: add collabora gtimelog

Collabora has a special gtimelog application which allows reporting to
its timelog servers. It can be trivially packaged by modifying the
existing gtimelog package from nixpkgs

Change-Id: I9fa7560d8a4a6412ed4b5f818909193aaf1ceeb3
Reviewed-on: https://git.clicks.codes/c/Chimera/NixFiles/+/704
Reviewed-by: Skyler Grey <minion@clicks.codes>
Tested-by: Skyler Grey <minion@clicks.codes>
Reviewed-by: Samuel Shuert <coded@clicks.codes>
diff --git a/flake.nix b/flake.nix
index b886ce7..a40d052 100644
--- a/flake.nix
+++ b/flake.nix
@@ -7,6 +7,15 @@
       inputs.nixpkgs.follows = "nixpkgs";
     };
 
+    collabora-gtimelog = {
+      url = "git+https://gitlab.collabora.com/collabora/gtimelog.git";
+      flake = false;
+    };
+    collabora-icon = {
+      url = "https://www.collabora.com/favicon.ico";
+      flake = false;
+    };
+
     ewwsalmoomedits--eww-widgets = {
       url = "github:saimoomedits/eww-widgets";
       flake = false;
@@ -51,6 +60,7 @@
         inputs.hyprland.homeManagerModules.default
         inputs.nur.hmModules.nur
         inputs.nix-index-database.hmModules.nix-index
+        inputs.sops-nix.homeManagerModules.sops
       ];
 
       systems.modules.nixos = [