feat: add collabora gtimelog

Collabora has a special gtimelog application which allows reporting to
its timelog servers. It can be trivially packaged by modifying the
existing gtimelog package from nixpkgs

Change-Id: I9fa7560d8a4a6412ed4b5f818909193aaf1ceeb3
Reviewed-on: https://git.clicks.codes/c/Chimera/NixFiles/+/704
Reviewed-by: Skyler Grey <minion@clicks.codes>
Tested-by: Skyler Grey <minion@clicks.codes>
Reviewed-by: Samuel Shuert <coded@clicks.codes>
diff --git a/packages/gtimelog-collabora/default.nix b/packages/gtimelog-collabora/default.nix
new file mode 100644
index 0000000..3581d37
--- /dev/null
+++ b/packages/gtimelog-collabora/default.nix
@@ -0,0 +1,39 @@
+{
+  inputs,
+  lib,
+  gtimelog,
+  glib-networking,
+  gtk3,
+  libsoup,
+  glib,
+  pango,
+  harfbuzz,
+  gdk-pixbuf,
+  atk,
+  libsecret,
+  gobject-introspection,
+  ...
+}:
+gtimelog.overrideAttrs (oldAttrs: {
+  src = inputs.collabora-gtimelog;
+  makeWrapperArgs = [
+    "--set GIO_MODULE_DIR ${lib.makeSearchPathOutput "out" "lib/gio/modules" [ glib-networking ]}"
+    "--set GI_TYPELIB_PATH ${
+      lib.makeSearchPathOutput "out" "lib/girepository-1.0" [
+        gtk3
+        libsoup
+        glib
+        pango
+        harfbuzz
+        gdk-pixbuf
+        atk
+        libsecret
+      ]
+    }"
+  ];
+  buildInputs = oldAttrs.buildInputs ++ [ glib-networking ];
+  nativeBuildInputs = oldAttrs.nativeBuildInputs ++ [ gobject-introspection ];
+  preInstall = ''
+    cp ${inputs.collabora-icon} src/gtimelog/gtimelog-large.png
+  '';
+})