Add yubikey options

coded@clicks.codes owns 2 YubiKeys, I own 3. It's therefore important to
have YubiKey options. In particular, we need to install and configure
the following programs

- ykman: A good tool for configuring YubiKeys, it's what we use, at
         least
- pcscd: A daemon required for ykman, we also use it with pgp by using
         the disable-ccid option for its smartcard daemon
- scdaemon: The smartcard daemon used by pgp, interfaces with YubiKeys
            for pgp smartcard operations. It uses either its own thing
	    (ccid) which conflicts with pcscd (and therefore ykman) or
	    pcscd. We want it to use pcscd

Change-Id: I237274c2c6362d3201a34828e34d55fdb9f35258
Reviewed-on: https://git.clicks.codes/c/Chimera/NixFiles/+/431
Tested-by: Skyler Grey <minion@clicks.codes>
Reviewed-by: Samuel Shuert <coded@clicks.codes>
diff --git a/homes/x86_64-linux/minion@greylag/default.nix b/homes/x86_64-linux/minion@greylag/default.nix
index 101a6bd..d2233fb 100644
--- a/homes/x86_64-linux/minion@greylag/default.nix
+++ b/homes/x86_64-linux/minion@greylag/default.nix
@@ -23,10 +23,6 @@
     greylag
   '';
 
-  programs.gpg.scdaemonSettings = {
-    reader-port = "Yubico Yubi";
-  };
-
   programs.git.extraConfig.alias = {
     recommit = "!git commit --verbose -eF $(git rev-parse --git-dir)/COMMIT_EDITMSG";
     graph = "log --graph --oneline --decorate";
@@ -149,6 +145,8 @@
       minecraft.enable = true;
       itch.enable = true;
     };
+
+    yubikey.enable = true;
   };
 
   services.nextcloud-client = {