Add nix-index-database and comma

Nix-index-database is a premade database for nix-index. The process of
downloading a database is often rather slow, so building one into the
system config automatically makes sense

Comma is a command which integrates with nix-index to autorun commands
with the ability to detect what package a command is in. Using it allows
you to more easily run commands without having to go to search.nixos.org
and use nix shell or nix run

Change-Id: Ib44b65294152354a9ca433ad2315ddb2fcd8caa4
Reviewed-on: https://git.clicks.codes/c/Chimera/NixFiles/+/427
Tested-by: Skyler Grey <minion@clicks.codes>
Reviewed-by: Skyler Grey <minion@clicks.codes>
diff --git a/flake.nix b/flake.nix
index e93f5fd..9f08db1 100644
--- a/flake.nix
+++ b/flake.nix
@@ -45,15 +45,12 @@
       	inputs.anyrun.homeManagerModules.default
       	inputs.hyprland.homeManagerModules.default
       	inputs.nur.hmModules.nur
+        inputs.nix-index-database.hmModules.nix-index
       ];
     in inputs.snowfall-lib.mkFlake {
       inherit inputs;
       src = ./.;
 
-      # homes.modules = [
-      # TODO: inputs.nix-index-database.hmModules.nix-index
-      # ];
-
       homes.users."coded@shorthair".modules = extraHomeModules;
 
       homes.users."minion@greylag".modules = extraHomeModules;