feat(compositors)!: Add niri

According to its github page, niri is "A scrollable-tiling Wayland
compositor". Myself and coded have been looking for alternatives to
hyprland for stability and community reasons, and niri looks reasonable
for us

It's possible we'll remove hyprland altogether. If we do, we plan to
still maintain a more traditional compositor (e.g. swayfx)

BREAKING-CHANGE: This patch renames some hyprland options
Change-Id: I170dde769b55ebb32a3212a54012443fb4d0faf8
diff --git a/flake.nix b/flake.nix
index 617732f..dc58a3b 100644
--- a/flake.nix
+++ b/flake.nix
@@ -41,6 +41,15 @@
       inputs.nixpkgs.follows = "nixpkgs";
     };
 
+    niri-flake = {
+      url = "github:sodiboo/niri-flake";
+      inputs = {
+        niri-unstable.follows = "niri-flake/niri-stable";
+        nixpkgs.follows = "nixpkgs";
+        nixpkgs-stable.follows = "nixpkgs";
+      };
+    };
+
     nix-index-database = {
       url = "github:nix-community/nix-index-database";
       inputs.nixpkgs.follows = "nixpkgs";
@@ -68,11 +77,16 @@
       inherit inputs;
       src = ./.;
 
+      overlays = [
+        inputs.niri-flake.overlays.niri
+      ];
+
       homes.modules = [
         inputs.anyrun.homeManagerModules.default
         inputs.nur.hmModules.nur
         inputs.nix-index-database.hmModules.nix-index
         inputs.sops-nix.homeManagerModules.sops
+        inputs.niri-flake.homeModules.niri
       ];
 
       systems.modules.nixos = [