Initial commit

- Create a basic bootable system with Hyprland, a browser and some
  basic utilities

Change-Id: I4178e1185de319c45c6a4f2711fe035f50777e08
diff --git a/homes/x86_64-linux/minion@greylag/default.nix b/homes/x86_64-linux/minion@greylag/default.nix
new file mode 100644
index 0000000..6632942
--- /dev/null
+++ b/homes/x86_64-linux/minion@greylag/default.nix
@@ -0,0 +1,25 @@
+{
+    # Snowfall Lib provides a customized `lib` instance with access to your flake's library
+    # as well as the libraries available from your flake's inputs.
+    lib,
+    # An instance of `pkgs` with your overlays and packages applied is also available.
+    pkgs,
+    # You also have access to your flake's inputs.
+    inputs,
+
+    # Additional metadata is provided by Snowfall Lib.
+    home, # The home architecture for this host (eg. `x86_64-linux`).
+    target, # The Snowfall Lib target for this home (eg. `x86_64-home`).
+    format, # A normalized name for the home target (eg. `home`).
+    virtual, # A boolean to determine whether this home is a virtual target using nixos-generators.
+    host, # The host name for this home.
+
+    # All other arguments come from the home home.
+    config,
+    ...
+}:
+{
+    home.file.".snowfall.systemname".text = ''
+      greylag
+    '';
+}