Initial commit

- Create a basic bootable system with Hyprland, a browser and some
  basic utilities

Change-Id: I4178e1185de319c45c6a4f2711fe035f50777e08
diff --git a/modules/home/gestures/default.nix b/modules/home/gestures/default.nix
new file mode 100644
index 0000000..6abbbe4
--- /dev/null
+++ b/modules/home/gestures/default.nix
@@ -0,0 +1,11 @@
+{ lib, config, ... }: {
+  options.minion.touchpadGestures.enable = lib.mkEnableOption "Enable touchpad gestures";
+
+  config = lib.mkIf config.minion.touchpadGestures.enable {
+    services.fusuma.enable = true;
+
+    systemd.user.startServices = "sd-switch";
+
+    systemd.user.services.fusuma.Unit.X-Restart-Triggers = [ config.xdg.configFile."fusuma/config.yaml".source ];
+  };
+}
\ No newline at end of file