Add mini's password to shorthair system

Before this Minion was unable to sudo on @shorthair, this change fixes
this.

Change-Id: I2c1f0f568ef9662104be9143ff43165930836438
Reviewed-on: https://git.clicks.codes/c/Chimera/NixFiles/+/504
Tested-by: Skyler Grey <minion@clicks.codes>
Reviewed-by: Skyler Grey <minion@clicks.codes>
diff --git a/systems/x86_64-linux/shorthair/users/default.nix b/systems/x86_64-linux/shorthair/users/default.nix
index b305f99..24e854a 100644
--- a/systems/x86_64-linux/shorthair/users/default.nix
+++ b/systems/x86_64-linux/shorthair/users/default.nix
@@ -3,6 +3,9 @@
   users.users.coded.hashedPasswordFile =
     config.sops.secrets."systems/x86_64-linux/shorthair/users/passwords.sops.coded.json:coded".path;
 
+  users.users.minion.hashedPasswordFile =
+    config.sops.secrets."systems/x86_64-linux/shorthair/users/passwords.sops.coded.json:minion".path;
+
   sops.secrets."systems/x86_64-linux/shorthair/users/passwords.sops.coded.json:coded" = {
     mode = "0400";
     owner = config.users.users.root.name;
@@ -12,4 +15,14 @@
     key = "coded";
     neededForUsers = true;
   };
+
+  sops.secrets."systems/x86_64-linux/shorthair/users/passwords.sops.coded.json:minion" = {
+    mode = "0400";
+    owner = config.users.users.root.name;
+    group = config.users.users.root.group;
+    sopsFile = ./passwords.sops.coded.json;
+    format = "json";
+    key = "minion";
+    neededForUsers = true;
+  };
 }