Wayland touchpad options + Pinea config

Change-Id: I74994cf455b7dbd79a08ba41fa6a0922bbfaf670

Author: PineaFan <pineafan@clicks.codes>
Change-Id: I8c893e504671c6894d095b12f522c59d34656307
Reviewed-on: https://git.clicks.codes/c/Chimera/NixFiles/+/845
Reviewed-by: Samuel Shuert <coded@clicks.codes>
Tested-by: PineaFan <pineafan@clicks.codes>
diff --git a/systems/x86_64-linux/saurosuchus/default.nix b/systems/x86_64-linux/saurosuchus/default.nix
index 6341e28..a4ce57c 100644
--- a/systems/x86_64-linux/saurosuchus/default.nix
+++ b/systems/x86_64-linux/saurosuchus/default.nix
@@ -1,6 +1,7 @@
-{ ... }:
+{ pkgs, ... }:
 {
   imports = [
+    ./audio
     ./console
     ./compositor
     ./games
@@ -13,4 +14,17 @@
     ./time
     ./yubikey
   ];
+
+  config.services.postgresql = {
+    enable = true;
+    ensureDatabases = [ "graphite" "development" ];
+    enableTCPIP = true;
+    authentication = pkgs.lib.mkOverride 10 ''
+      #type database DBuser auth-method
+      local all all trust
+
+      host all all 127.0.0.1/32 trust
+      host all all ::1/128 trust
+    '';
+  };
 }