feat(systems): Add new system ocicat

Coded has gotten a new laptop and therefore needs another system, this
is that

Change-Id: I4287715eda72de11055360a0342c03898496c810
Reviewed-on: https://git.clicks.codes/c/Chimera/NixFiles/+/762
Tested-by: Samuel Shuert <coded@clicks.codes>
Reviewed-by: Samuel Shuert <coded@clicks.codes>
diff --git a/homes/x86_64-linux/coded@ocicat/default.nix b/homes/x86_64-linux/coded@ocicat/default.nix
new file mode 100644
index 0000000..eb3c115
--- /dev/null
+++ b/homes/x86_64-linux/coded@ocicat/default.nix
@@ -0,0 +1,48 @@
+{
+  # Snowfall Lib provides a customized `lib` instance with access to your flake's library
+  # as well as the libraries available from your flake's inputs.
+  lib,
+  # An instance of `pkgs` with your overlays and packages applied is also available.
+  pkgs,
+  # You also have access to your flake's inputs.
+  inputs,
+
+  # Additional metadata is provided by Snowfall Lib.
+  home, # The home architecture for this host (eg. `x86_64-linux`).
+  target, # The Snowfall Lib target for this home (eg. `x86_64-home`).
+  format, # A normalized name for the home target (eg. `home`).
+  virtual, # A boolean to determine whether this home is a virtual target using nixos-generators.
+  host, # The host name for this home.
+
+  # All other arguments come from the home home.
+  config,
+  ...
+}:
+{
+  chimera.users.coded.enable = true;
+
+  chimera.waybar.modules = {
+    laptop.enable = true;
+    temperature.hwmonPath = "/sys/class/hwmon/hwmon4/temp1_input";
+  };
+
+  chimera.niri = {
+    enable = true;
+
+    monitors = {
+      "eDP-1" = {
+        mode = {
+          width = 2560;
+          height = 1600;
+          refresh = 165.;
+        };
+        position = {
+          x = 0;
+          y = 0;
+        };
+      };
+    };
+  };
+
+  chimera.theme.wallpaper = ./wallpaper.png;
+}