feat(systems): Add new system ocicat

Coded has gotten a new laptop and therefore needs another system, this
is that

Change-Id: I4287715eda72de11055360a0342c03898496c810
Reviewed-on: https://git.clicks.codes/c/Chimera/NixFiles/+/762
Tested-by: Samuel Shuert <coded@clicks.codes>
Reviewed-by: Samuel Shuert <coded@clicks.codes>
diff --git a/systems/x86_64-linux/ocicat/networking/default.nix b/systems/x86_64-linux/ocicat/networking/default.nix
new file mode 100644
index 0000000..5b990ba
--- /dev/null
+++ b/systems/x86_64-linux/ocicat/networking/default.nix
@@ -0,0 +1,7 @@
+{ lib, config, ... }:
+{
+  networking = {
+    hostName = "ocicat";
+    useDHCP = lib.mkDefault true;
+  };
+}