feat(systems): Add new system ocicat
Coded has gotten a new laptop and therefore needs another system, this
is that
Change-Id: I4287715eda72de11055360a0342c03898496c810
Reviewed-on: https://git.clicks.codes/c/Chimera/NixFiles/+/762
Tested-by: Samuel Shuert <coded@clicks.codes>
Reviewed-by: Samuel Shuert <coded@clicks.codes>
diff --git a/systems/x86_64-linux/ocicat/users/default.nix b/systems/x86_64-linux/ocicat/users/default.nix
new file mode 100644
index 0000000..cf0e733
--- /dev/null
+++ b/systems/x86_64-linux/ocicat/users/default.nix
@@ -0,0 +1,28 @@
+{ config, ... }:
+{
+ users.users.coded.hashedPasswordFile =
+ config.sops.secrets."systems/x86_64-linux/ocicat/users/passwords.sops.coded.json:coded".path;
+
+ users.users.minion.hashedPasswordFile =
+ config.sops.secrets."systems/x86_64-linux/ocicat/users/passwords.sops.coded.json:minion".path;
+
+ sops.secrets."systems/x86_64-linux/ocicat/users/passwords.sops.coded.json:coded" = {
+ mode = "0400";
+ owner = config.users.users.root.name;
+ group = config.users.users.root.group;
+ sopsFile = ./passwords.sops.coded.json;
+ format = "json";
+ key = "coded";
+ neededForUsers = true;
+ };
+
+ sops.secrets."systems/x86_64-linux/ocicat/users/passwords.sops.coded.json:minion" = {
+ mode = "0400";
+ owner = config.users.users.root.name;
+ group = config.users.users.root.group;
+ sopsFile = ./passwords.sops.coded.json;
+ format = "json";
+ key = "minion";
+ neededForUsers = true;
+ };
+}