feat(shorthair): Add Ollama and webUI for it

Change-Id: I9863a3d4c9349e66209198ae5bd9a979dbf49da2
Reviewed-on: https://git.clicks.codes/c/Chimera/NixFiles/+/736
Tested-by: Skyler Grey <minion@clicks.codes>
Reviewed-by: Skyler Grey <minion@clicks.codes>
diff --git a/systems/x86_64-linux/shorthair/assistant/default.nix b/systems/x86_64-linux/shorthair/assistant/default.nix
new file mode 100644
index 0000000..c9ac91d
--- /dev/null
+++ b/systems/x86_64-linux/shorthair/assistant/default.nix
@@ -0,0 +1,11 @@
+{  # look at https://github.com/mozilla/DeepSpeech
+# stop building rocblas, use https://search.nixos.org/packages?channel=unstable&show=rocmPackages.rocblas&from=0&size=50&sort=relevance&type=packages&query=rocblas
+  services.ollama = {
+    enable = true;
+    acceleration = "rocm";
+  };
+  services.nextjs-ollama-llm-ui = {
+    enable = true;
+    port = 1144;
+  };
+}