fix(options)!: Fix option names to be more categorical

Chimera users have been moved to chimera.users.<name> and touchpad is
now under chimera.input.touchpad.enable.

Everything using these options has been updated to point to the correct path

Change-Id: I9873f39378da0dc877d73f97769105c464a1780d
Reviewed-on: https://git.clicks.codes/c/Chimera/NixFiles/+/760
Reviewed-by: Skyler Grey <minion@clicks.codes>
Tested-by: Samuel Shuert <coded@clicks.codes>
diff --git a/modules/home/gestures/default.nix b/modules/home/gestures/default.nix
index c471fcb..d118ff6 100644
--- a/modules/home/gestures/default.nix
+++ b/modules/home/gestures/default.nix
@@ -1,9 +1,9 @@
 { lib, config, ... }:
 {
-  options.chimera.touchpad.enable = lib.mkEnableOption "Enable touchpad gestures";
+  options.chimera.input.touchpad.enable = lib.mkEnableOption "Enable touchpad gestures";
 
 
-  config = lib.mkIf (config.chimera.touchpad.enable && config.chimera.hyprland.enable) {
+  config = lib.mkIf (config.chimera.input.touchpad.enable && config.chimera.hyprland.enable) {
     services.fusuma.enable = true;
 
     systemd.user.startServices = "sd-switch";