fix(options)!: Fix option names to be more categorical

Chimera users have been moved to chimera.users.<name> and touchpad is
now under chimera.input.touchpad.enable.

Everything using these options has been updated to point to the correct path

Change-Id: I9873f39378da0dc877d73f97769105c464a1780d
Reviewed-on: https://git.clicks.codes/c/Chimera/NixFiles/+/760
Reviewed-by: Skyler Grey <minion@clicks.codes>
Tested-by: Samuel Shuert <coded@clicks.codes>
diff --git a/modules/home/users/minion/default.nix b/modules/home/users/minion/default.nix
index f1da848..a7edcb0 100644
--- a/modules/home/users/minion/default.nix
+++ b/modules/home/users/minion/default.nix
@@ -1,8 +1,8 @@
 { inputs, config, lib, pkgs, ... }:
 {
-  options.chimera.minion.enable = lib.mkEnableOption "Enable Chimera options for minion";
+  options.chimera.users.minion.enable = lib.mkEnableOption "Enable Chimera options for minion";
 
-  config = lib.mkIf config.chimera.minion.enable (let
+  config = lib.mkIf config.chimera.users.minion.enable (let
     git_emails = {
       personal = "sky@a.starrysky.fyi";
       collabora = "skyler.grey@collabora.com";