blob: d710c95d01b49b0740665c72708b1f60851cf1d3 [file] [log] [blame]
Skyler Grey4e230892024-02-13 22:58:46 +00001{
2 # Snowfall Lib provides a customized `lib` instance with access to your flake's library
3 # as well as the libraries available from your flake's inputs.
4 lib,
5 # An instance of `pkgs` with your overlays and packages applied is also available.
6 pkgs,
7 # You also have access to your flake's inputs.
8 inputs,
9
10 # Additional metadata is provided by Snowfall Lib.
11 home, # The home architecture for this host (eg. `x86_64-linux`).
12 target, # The Snowfall Lib target for this home (eg. `x86_64-home`).
13 format, # A normalized name for the home target (eg. `home`).
14 virtual, # A boolean to determine whether this home is a virtual target using nixos-generators.
15 host, # The host name for this home.
16
17 # All other arguments come from the home home.
18 config,
19 ...
20}:
21{
22 chimera = {
23 hyprland = {
24 enable = true;
25
26 monitors = [
27 "DP-1,1920x1080@165,0x0,1"
28 "DP-2,1920x1080@165,1920x0,1"
29 "HDMI-A-1,1920x1080@60,960x-1080,1"
30 ];
31
32 hyprpaper = {
33 splash = {
34 enable = true;
35 offset = -0.6;
36 };
37 };
38 };
39 wallpaper = ./wallpaper.png;
40
41 browser = {
42 firefox = {
43 enable = true;
44 extraExtensions = [
45 config.nur.repos.rycee.firefox-addons.simple-tab-groups
46 ];
47 };
48
49 chromium = {
50 enable = true;
51 extensions = {
52 bitwarden.enable = true;
53 youtube = {
54 sponsorBlock.enable = true;
55 returnDislike.enable = true;
56 deArrow.enable = true;
57 };
58 reactdevtools.enable = true;
59 ublockOrigin.enable = true;
60 };
61 extraExtensions = [
62 { id = "gmkiokemhjjdjmpnnjmnpkpfoenpnpne"; } #Lofi Girl
63 { id = "bmnlcjabgnpnenekpadlanbbkooimhnj"; } #PayPal Honey
64 { id = "kekjfbackdeiabghhcdklcdoekaanoel"; } #MAL Sync
65 ];
66 };
67 };
68
69 theme.catppuccin = {
70 enable = true;
71 style = "Macchiato";
72 color = "Blue";
73 };
74 };
75}