Add a nix flake to have a devshell
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..2ee4b77
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,14 @@
+{
+ description = "A basic flake with a shell";
+ inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
+ inputs.flake-utils.url = "github:numtide/flake-utils";
+
+ outputs = { self, nixpkgs, flake-utils }:
+ flake-utils.lib.eachDefaultSystem (system: let
+ pkgs = nixpkgs.legacyPackages.${system};
+ in {
+ devShells.default = pkgs.mkShell {
+ packages = [ pkgs.yarn pkgs.nodejs-19_x ];
+ };
+ });
+}