Create a direnv/nix environment
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..f8ce4ba
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,15 @@
+{
+  description = "A basic flake with a shell";
+  inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
+  inputs.flake-utils.url = "github:numtide/flake-utils";
+
+  outputs = { self, nixpkgs, flake-utils }:
+    flake-utils.lib.eachDefaultSystem (system: let
+      pkgs = nixpkgs.legacyPackages.${system};
+    in {
+      devShells.default = pkgs.mkShell {
+        nativeBuildInputs = with pkgs; [yarn nodejs-18_x];
+        buildInputs = [ ];
+      };
+    });
+}