Switch to pnpm

In production, we've been using pnpm for a little while. This commit
makes the version on gerrit have parity with our production environment

Change-Id: I072c92626c983fe627f8477f4e6942d5fa0a25f5
Reviewed-on: https://git.clicks.codes/c/Clicks/clicks.codes/+/183
Tested-by: Skyler Grey <minion@clicks.codes>
Reviewed-by: Samuel Shuert <coded@clicks.codes>
diff --git a/flake.nix b/flake.nix
index f8ce4ba..dd5407d 100644
--- a/flake.nix
+++ b/flake.nix
@@ -8,7 +8,7 @@
       pkgs = nixpkgs.legacyPackages.${system};
     in {
       devShells.default = pkgs.mkShell {
-        nativeBuildInputs = with pkgs; [yarn nodejs-18_x];
+        nativeBuildInputs = with pkgs; [nodejs-18_x nodePackages.pnpm];
         buildInputs = [ ];
       };
     });