disable mongo, update System Version to 23.11
Change-Id: Iedf8bba405afbc6b5008463e006bdbecb4294707
Reviewed-on: https://git.clicks.codes/c/Coded/nixConfig/+/96
Reviewed-by: Samuel Shuert <coded@clicks.codes>
Tested-by: Samuel Shuert <coded@clicks.codes>
diff --git a/modules/audio.nix b/modules/audio.nix
index 14f2167..4046f2b 100644
--- a/modules/audio.nix
+++ b/modules/audio.nix
@@ -1,16 +1,34 @@
-{ config, pkgs, ... }: {
+{ config, pkgs, lib, inputs, ... }: {
sound.enable = true;
hardware.pulseaudio.enable = false;
security.rtkit.enable = true;
+
services.pipewire = {
enable = true;
alsa.enable = true;
alsa.support32Bit = true;
pulse.enable = true;
+ jack.enable = true;
};
+ environment.etc."pipewire/pipewire.conf.d/VirtualAudioDevice.conf".text = ''
+ context.objects = [
+ {
+ factory = adapter
+ args = {
+ factory.name = support.null-audio-sink
+ node.name = Microphone-Proxy
+ node.description = Microphone
+ media.class = Audio/Source/Virtual
+ audio.posistion = MONO
+ }
+ }
+ ]
+ '';
+
home-manager.users.coded.home.packages =
with pkgs; [
+ audacity
helvum
lmms
];