disable mongo, update System Version to 23.11

Change-Id: Iedf8bba405afbc6b5008463e006bdbecb4294707
Reviewed-on: https://git.clicks.codes/c/Coded/nixConfig/+/96
Reviewed-by: Samuel Shuert <coded@clicks.codes>
Tested-by: Samuel Shuert <coded@clicks.codes>
diff --git a/modules/shell.nix b/modules/shell.nix
index 6d66e7b..2deaa16 100644
--- a/modules/shell.nix
+++ b/modules/shell.nix
@@ -2,6 +2,11 @@
   programs.zsh.enable = true;
   users.users.coded.shell = pkgs.zsh;
 
+  environment.systemPackages = with pkgs; [
+    bmon
+    wget
+  ];
+
   home-manager.users.coded.programs = {
     # ZSH
     zsh = {
@@ -16,6 +21,8 @@
         "gr!" = "git review";
         clr = "clear";
         pnpx = "pnpm dlx";
+        print3d = "sudo /run/current-system/sw/bin/pronsole.py";
+        nh = "wget -O ~/Documents/hashCheck $1 | nix hash file ~/Documents/hashCheck";
       };
 
       dirHashes = { code = "$HOME/Documents/programming"; };
@@ -28,7 +35,7 @@
         plugins = [ "git" ];
       };
     };
-
+    
     # Starship
     starship = {
       enable = true;
@@ -49,38 +56,6 @@
       };
     };
 
-    # htop
-    # htop = {
-    #   enable = true;
-    #   settings = {
-    #     color_scheme = 6;
-    #     cpu_count_from_one = 0;
-    #     delay = 15;
-    #     fields = with home-manager.config.lib.htop.fields; [
-    #       PID
-    #       USER
-    #       PERCENT_CPU
-    #       PERCENT_MEM
-    #       M_SIZE
-    #       M_RESIDENT
-    #       M_SHARE
-    #       STATE
-    #       TIME
-    #       COMM
-    #     ];
-    #   } // (with home-manager.config.lib.htop; leftMeters [
-    #     (bar "AllCPUs2")
-    #     (bar "Memory")
-    #     (bar "Swap")
-    #     (text "Zram")
-    #   ]) // (with home-manager.config.lib.htop; rightMeters [
-    #     (text "Tasks")
-    #     (text "LoadAverage")
-    #     (text "Uptime")
-    #     (text "Systemd")
-    #   ]);
-    # };
-
     # Nix-index
     nix-index.enable = true;