Add neovim as default editor
Change-Id: I6487378b680210cc815234a1d9d06ac0b3aa9309
Reviewed-on: https://git.clicks.codes/c/Coded/nixConfig/+/98
Reviewed-by: Samuel Shuert <coded@clicks.codes>
Tested-by: Samuel Shuert <coded@clicks.codes>
diff --git a/modules/shell.nix b/modules/shell.nix
index 2deaa16..66bf1ea 100644
--- a/modules/shell.nix
+++ b/modules/shell.nix
@@ -5,6 +5,7 @@
environment.systemPackages = with pkgs; [
bmon
wget
+ ripgrep
];
home-manager.users.coded.programs = {
@@ -23,6 +24,9 @@
pnpx = "pnpm dlx";
print3d = "sudo /run/current-system/sw/bin/pronsole.py";
nh = "wget -O ~/Documents/hashCheck $1 | nix hash file ~/Documents/hashCheck";
+ edit = "nvim";
+ neovim = "nvim";
+ v = "nvim";
};
dirHashes = { code = "$HOME/Documents/programming"; };