Add Yazi CMDL File Explorer

Change-Id: I242080947a32da5487eed0ef6f29ea390f9d331a
Reviewed-on: https://git.clicks.codes/c/Coded/nixConfig/+/368
Tested-by: Samuel Shuert <coded@clicks.codes>
Reviewed-by: Samuel Shuert <coded@clicks.codes>
diff --git a/modules/common/files.nix b/modules/common/files.nix
new file mode 100644
index 0000000..111437d
--- /dev/null
+++ b/modules/common/files.nix
@@ -0,0 +1,7 @@
+{ pkgs, flakeRoot, ... }: {
+  home-manager.users.coded.programs.yazi = {
+    enable = true;
+    enableZshIntegration = true;
+    theme = builtins.fromTOML (builtins.readFile "${flakeRoot}/extensions/yazi/catppuccin-macchiato-theme.toml");
+  };
+}