Update to nixos 23.05

- Update using patch notes
- Remove etherpad which didn't work
- Remove code-server which depended on deprecated nodejs versions and was unused
- Remove pkgs-unstable
- Update nodejs to nodejs-20
diff --git a/modules/dnsmasq.nix b/modules/dnsmasq.nix
index 3d3b6bd..51dd06d 100644
--- a/modules/dnsmasq.nix
+++ b/modules/dnsmasq.nix
@@ -3,12 +3,12 @@
     nscd.enableNsncd = true;
     dnsmasq = {
       enable = true;
-      servers = [ "1.1.1.1" "1.0.0.1" ];
-      extraConfig = ''
-        local=/local/
-        domain=local
-        expand-hosts
-      '';
+      settings = {
+        servers = [ "1.1.1.1" "1.0.0.1" ];
+        local = "/local/";
+        domain = "local";
+        expand-hosts = true;
+      };
     };
     avahi = {
       enable = true;