Update to nixos 23.05

- Update using patch notes
- Remove etherpad which didn't work
- Remove code-server which depended on deprecated nodejs versions and was unused
- Remove pkgs-unstable
- Update nodejs to nodejs-20
diff --git a/modules/git.nix b/modules/git.nix
index dac2036..747f686 100644
--- a/modules/git.nix
+++ b/modules/git.nix
@@ -3,8 +3,6 @@
 
   services.gitea = {
     enable = false;
-    rootUrl = "https://git.clicks.codes/";
-    httpPort = 6064;
     settings.mailer = {
       ENABLED = true;
       FROM = "git@clicks.codes";
@@ -25,6 +23,8 @@
       DEFAULT_ENABLE_TIMETRACKING = true;
     };
     settings.server = {
+      ROOT_URL = "https://git.clicks.codes/";
+      HTTP_PORT = 6064;
       SSH_DOMAIN = "ssh.clicks.codes";
       DOMAIN = "localhost";
       DISABLE_SSH = false;