Update to nixos 23.05

- Update using patch notes
- Remove etherpad which didn't work
- Remove code-server which depended on deprecated nodejs versions and was unused
- Remove pkgs-unstable
- Update nodejs to nodejs-20
diff --git a/modules/ssh.nix b/modules/ssh.nix
new file mode 100644
index 0000000..70e1ebb
--- /dev/null
+++ b/modules/ssh.nix
@@ -0,0 +1,7 @@
+{
+  services.openssh = {
+    enable = true;
+    settings.PasswordAuthentication = false;
+  };
+  networking.firewall.allowedTCPPorts = [ 22 ];
+}