Enable Mjolnir

Mjolnir is our moderation bot for matrix. It was disabled when the server went
down, but now the server is back up we should have it again

Change-Id: I4e8d3377d1c0916c3afba32a0489e1fbd2c5e74c
Reviewed-on: https://git.clicks.codes/c/Clicks/NixFiles/+/21
Reviewed-by: Samuel Shuert <coded@clicks.codes>
Tested-by: Skyler Grey <minion@clicks.codes>
diff --git a/modules/common/matrix.nix b/modules/common/matrix.nix
index 5e865bd..2694826 100644
--- a/modules/common/matrix.nix
+++ b/modules/common/matrix.nix
@@ -85,7 +85,7 @@
   networking.firewall.allowedUDPPorts = [ 3478 5349 ];
 
   services.mjolnir = {
-    enable = false;
+    enable = true;
 
     settings = {
       autojoinOnlyIfManager = true;
@@ -160,13 +160,13 @@
       format = "binary";
       path = config.services.matrix-synapse.settings.signing_key_path;
     };
-    /*mjolnir_password = {
+    mjolnir_password = {
       mode = "0600";
       owner = config.users.users.mjolnir.name;
       group = config.users.users.mjolnir.group;
       sopsFile = ../../secrets/matrix.json;
       format = "json";
-    };*/
+    };
   };
 } (let isDerived = base != null;
 in if isDerived