Add gerrit
Gerrit is a service which provides code review via "changes" (commits) which you
can continually amend, viewing the diffs between them in a very similar way to
<https://graphite.dev/> (which is awesome but too expensive for Clicks to
justify). We hope it'll provide some better structure than the GitHub workflow
we have been using
Still TODO (in a followup change):
- The bazel build for the oauth module is horrible and introduces tips from
<https://zimbatm.com/notes/nix-packaging-the-heretic-way>. This is generally
considered a bad thing. We should change this
- Gerrit cannot yet send emails
Change-Id: I1393b2ae5a1efe049ea2170de46070d8789a2e3a
diff --git a/flake.nix b/flake.nix
index 838808d..11b4c88 100644
--- a/flake.nix
+++ b/flake.nix
@@ -58,6 +58,7 @@
./modules/ecryptfs.nix
./modules/fail2ban.nix
./modules/fuck.nix
+ ./modules/gerrit.nix
./modules/git.nix
./modules/grafana.nix
./modules/home-manager-users.nix
@@ -82,7 +83,7 @@
users.mutableUsers = false;
}
];
- specialArgs = { base = null; drive_paths = import ./variables/drive_paths.nix; };
+ specialArgs = { base = null; drive_paths = import ./variables/drive_paths.nix; inherit system; };
};
in
base.extendModules {