Add gerrit
Gerrit is a service which provides code review via "changes" (commits) which you
can continually amend, viewing the diffs between them in a very similar way to
<https://graphite.dev/> (which is awesome but too expensive for Clicks to
justify). We hope it'll provide some better structure than the GitHub workflow
we have been using
Still TODO (in a followup change):
- The bazel build for the oauth module is horrible and introduces tips from
<https://zimbatm.com/notes/nix-packaging-the-heretic-way>. This is generally
considered a bad thing. We should change this
- Gerrit cannot yet send emails
Change-Id: I1393b2ae5a1efe049ea2170de46070d8789a2e3a
diff --git a/modules/caddy/caddyfile.nix b/modules/caddy/caddyfile.nix
index 0b2acf4..4334549 100644
--- a/modules/caddy/caddyfile.nix
+++ b/modules/caddy/caddyfile.nix
@@ -377,6 +377,10 @@
"syncthing.thecoded.prof"
"syncthing.hopescaramels.com"
] [ "localhost:8384" ])
+ (HTTPReverseProxyRoute [
+ "git.clicks.codes"
+ "gerrit.clicks.codes"
+ ] [ "127.0.0.255:1000" ])
(PHPRoute
[ "paste.clicks.codes" "paste.coded.codes" ]
"${pkgs.privatebin}/share/privatebin"