Add nextcloud
Nextcloud will allow us to easily replace google docs with open source
alternatives such as Collabora Online.
Other options considered:
- Privatebin (not for collaborative document editing, we do have an instance at
https://paste.clicks.codes/)
- Etherpad (seemed to require a nontrivial amount of setup and an old version of
nodejs)
- Owncloud (looks good too, but Nextcloud is the offering I'm more familiar with
as I've used instances of it before (and some friends host it!))
- Standalone Collabora Online server (would need some other WOPI host or to use
filesystem... which, no)
- Cryptpad (I'm less familiar with it, and we don't seem to need the things
which are its selling points)
Still TODO (for followup changes):
- Integrate with Keycloak (added in I53e33f8c7fa21220e5407d4cd75a705c8e19f9a3)
for authentication
Change-Id: I8cf10ee09b068eb7d74cd2d5619b509eb9581f8d
diff --git a/modules/caddy/caddyfile.nix b/modules/caddy/caddyfile.nix
index 0b2acf4..4924c6f 100644
--- a/modules/caddy/caddyfile.nix
+++ b/modules/caddy/caddyfile.nix
@@ -382,6 +382,11 @@
"${pkgs.privatebin}/share/privatebin"
"unix/${config.services.phpfpm.pools.privatebin.socket}"
)
+ (PHPRoute
+ [ "cloud.clicks.codes" "nextcloud.clicks.codes" "docs.clicks.codes" ]
+ "${config.services.nextcloud.package}"
+ "unix/${config.services.phpfpm.pools.nextcloud.socket}"
+ )
];
};
srv1 = {