Add nextcloud

Nextcloud will allow us to easily replace google docs with open source
alternatives such as Collabora Online.

Other options considered:
- Privatebin (not for collaborative document editing, we do have an instance at
  https://paste.clicks.codes/)
- Etherpad (seemed to require a nontrivial amount of setup and an old version of
  nodejs)
- Owncloud (looks good too, but Nextcloud is the offering I'm more familiar with
  as I've used instances of it before (and some friends host it!))
- Standalone Collabora Online server (would need some other WOPI host or to use
  filesystem... which, no)
- Cryptpad (I'm less familiar with it, and we don't seem to need the things
  which are its selling points)

Still TODO (for followup changes):
- Integrate with Keycloak (added in I53e33f8c7fa21220e5407d4cd75a705c8e19f9a3)
  for authentication

Change-Id: I8cf10ee09b068eb7d74cd2d5619b509eb9581f8d
diff --git a/modules/privatebin.nix b/modules/privatebin.nix
index 5dd6a28..e82c389 100644
--- a/modules/privatebin.nix
+++ b/modules/privatebin.nix
@@ -1,7 +1,6 @@
 { config, lib, base, ... }:
 lib.recursiveUpdate
 {
-  services.nginx.enable = false; # PrivateBin attempts to enable nginx but we already use caddy
   services.privatebin = {
     enable = true;
     settings = {
@@ -17,7 +16,7 @@
 
         info = ''Powered by <a href="https://privatebin.info/">PrivateBin</a>. Provided as a service free-of-charge by Clicks. Come chat with us <a href="https://matrix.to/#/#global:coded.codes"> on Matrix</a>'';
         notice = "This service has no guarantee of uptime, and pastes are not backed up. If you need somewhere to host the last words of your wise old grandfather for time immemorial this is not the place.";
-        
+
         langaugeselection = true;
       };