Add keycloak
Keycloak is a login provider that we can host to give us SSO. This is preferable
to all of our services having different authentication capabilities, logins etc.
(e.g. mailu doesn't support 2fa: <https://github.com/Mailu/Mailu/issues/2222>!)
Change-Id: Ic0a5238a03d4d0b8a270c29a270c579b00aea799
diff --git a/modules/caddy/caddyfile.nix b/modules/caddy/caddyfile.nix
index 243e721..0b2acf4 100644
--- a/modules/caddy/caddyfile.nix
+++ b/modules/caddy/caddyfile.nix
@@ -370,6 +370,7 @@
}
))
(HTTPReverseProxyRoute [ "passwords.clicks.codes" ] [ "localhost:8452" ])
+ (HTTPReverseProxyRoute [ "login.clicks.codes" ] [ "localhost:9083" ])
(HTTPReverseProxyRoute [
"syncthing.clicks.codes"
"syncthing.coded.codes"