fix(nginx): Propagate dnsProvider to www hosts

When we auto-created www hosts, we made an oversight by not also
propagating dnsProvider. This caused an error when using www, which we
missed because our tests also didn't check for propagation of
dnsProvider

In the meantime, we need to update our unit tests for these functions,
as by missing out dnsProvider we have effectively nailed down its
nonexistence

Finally, we also add a regression test (auxolotl-eval.check.nix), based
on the real-life example that made this fail - provided by Auxolotl's
Jake Hamilton (thanks!). That file is licensed as Auxolotl's infra is

Change-Id: I8a08a29033b9d47ca43ce87f24fe17823a6da440
Reviewed-on: https://git.clicks.codes/c/Infra/NixFiles/+/817
Tested-by: Skyler Grey <minion@clicks.codes>
Reviewed-by: Samuel Shuert <coded@clicks.codes>
diff --git a/flake.nix b/flake.nix
index 1215be6..336b360 100644
--- a/flake.nix
+++ b/flake.nix
@@ -111,6 +111,16 @@
           allChecks = {
             deploy-rs = lib.deploy-rs.${channels.nixpkgs.system}.deployChecks inputs.self.deploy;
             clicks = lib.clicks.checks channels.nixpkgs;
+            adhoc = let
+              nixFiles = lib.snowfall.fs.get-nix-files-recursive ./.;
+              checkFiles = builtins.filter (lib.clicks.strings.endsWith ".check.nix") nixFiles;
+              importedChecks = lib.forEach checkFiles (file: {
+                name = builtins.unsafeDiscardStringContext (builtins.baseNameOf file);
+                value = import file {
+                  inherit channels lib inputs;
+                };
+              });
+            in builtins.listToAttrs importedChecks;
           };
 
           mergedChecks = lib.trivial.pipe allChecks [