Enable parsedmarc
Parsedmarc is a service to add a dmarc graph to our graphana instance.
We used it before, but disabled it before reviving email, etc. after we
had to start over on a1d2. It was never re-enabled.
The config has changed slightly, so some of the NixOS module defaults no
longer work. We have updated our config to match.
Change-Id: Id5af43f9bef0b845939d894e6b688f817d5dd59f
Reviewed-on: https://git.clicks.codes/c/Infra/NixFiles/+/542
Tested-by: Skyler Grey <minion@clicks.codes>
Reviewed-by: Samuel Shuert <coded@clicks.codes>
diff --git a/modules/common/dmarc.nix b/modules/common/dmarc.nix
index 62d847c..da7f1ec 100644
--- a/modules/common/dmarc.nix
+++ b/modules/common/dmarc.nix
@@ -21,16 +21,18 @@
];
services.parsedmarc = {
- enable = false;
+ enable = true;
settings.imap = {
host = "mail.clicks.codes";
user = "dmarc@clicks.codes";
password = { _secret = config.sops.secrets.imap_password.path; };
};
+ settings.smtp.to = [];
settings.mailbox = {
watch = true;
delete = false;
};
+ settings.elasticsearch.hosts = lib.mkForce [ "http://localhost:9200" ];
};
services.geoipupdate.settings = {
AccountID = 863877;