feat(storage): erase rootfs on boot

We want impermanence so that it's easier to keep track of what state we
have on our system, and what we should be rigrously backing up

This is the first step towards setting that up

Change-Id: I399a7035237f02172180be559c9340faba40af47
Reviewed-on: https://git.clicks.codes/c/Infra/NixFiles/+/722
Reviewed-by: Samuel Shuert <coded@clicks.codes>
Tested-by: Samuel Shuert <coded@clicks.codes>
diff --git a/systems/x86_64-linux/a1d1/default.nix b/systems/x86_64-linux/a1d1/default.nix
index 1bca337..3add29d 100644
--- a/systems/x86_64-linux/a1d1/default.nix
+++ b/systems/x86_64-linux/a1d1/default.nix
@@ -27,6 +27,13 @@
     services = {
       ssh.enable = true;
     };
+
+    storage = {
+      impermanence = {
+        enable = true;
+        device = "/dev/disk/by-uuid/ab5c2f52-a737-4b29-a505-e3d0b9d0714c";
+      };
+    };
   };
 
   boot.initrd.availableKernelModules = [
@@ -42,10 +49,10 @@
   boot.kernelModules = [ "kvm-amd" ];
   boot.extraModulePackages = [ ];
 
-  fileSystems."/" = {
+  fileSystems."/nix" = {
     device = "/dev/disk/by-uuid/ab5c2f52-a737-4b29-a505-e3d0b9d0714c";
     fsType = "btrfs";
-    options = [ "subvol=@" ];
+    options = [ "subvol=@nix" ];
   };
 
   fileSystems."/boot" = {