fix(non-clicks): Ensure all modules start disabled

Clicks wants some modules (our backups, secrets and users) enabled by
default. Auxolotl wants to import our modules, and they don't want any
of this stuff.

Importing modules one-by-one is a potential solution, but is rather
messy given things like impermanence which is depended on in lots of
places. It's much cleaner to know whether the current flake is Clicks
and enable/disable defaults based on that

Change-Id: Icfb6d7bacdfbc31f1904ea4a1b6d6e577b03fa09
Reviewed-on: https://git.clicks.codes/c/Infra/NixFiles/+/802
Tested-by: Skyler Grey <minion@clicks.codes>
Reviewed-by: Skyler Grey <minion@clicks.codes>
diff --git a/modules/nixos/clicks/defaults/default.nix b/modules/nixos/clicks/defaults/default.nix
new file mode 100644
index 0000000..1e42c6f
--- /dev/null
+++ b/modules/nixos/clicks/defaults/default.nix
@@ -0,0 +1,8 @@
+{ lib, ... }: {
+  options.clicks.defaults.enable = lib.mkOption {
+    type = lib.types.bool;
+    example = true;
+    default = false;
+    description = "Tell Clicks modules that they are allowed to be default-enabled. Clicks modules are designed to be all imported at once, so without this we will assume we're running on someone-else's system and avoid setting anything without being told to";
+  };
+}