test(modules): Check eval is identical to nixpkgs
We want these modules to be importable by people, as a set, even if they
don't want to use all of the options or import all of the dependencies
This test makes sure of 2 things
- Our modules can be evaluated on the default configuration with only
stuff that is permitted in our README
- Without some configuration, our modules do not change the outputted
system toplevel
This can be used as a rough proxy for being "safe to import", as
hopefully these modules won't introduce any changes to your config from
only an import
Change-Id: Ied99c3460a76f205de1724db2c531723cc3506b5
Reviewed-on: https://git.clicks.codes/c/Infra/NixFiles/+/812
Reviewed-by: Skyler Grey <minion@clicks.codes>
Tested-by: Skyler Grey <minion@clicks.codes>
diff --git a/flake.nix b/flake.nix
index 5500287..1215be6 100644
--- a/flake.nix
+++ b/flake.nix
@@ -100,7 +100,7 @@
importedSpecs = lib.forEach specFiles (file: {
name = builtins.unsafeDiscardStringContext (builtins.baseNameOf file);
value = import file {
- inherit channels lib;
+ inherit channels lib inputs;
};
});
in builtins.listToAttrs importedSpecs;