Add basic services necessary for running projects
diff --git a/flake.nix b/flake.nix
index b384e79..fd1a07b 100644
--- a/flake.nix
+++ b/flake.nix
@@ -4,24 +4,30 @@
inputs.deploy-rs.url = "github:serokell/deploy-rs";
outputs = { self, nixpkgs, deploy-rs, ... }@inputs: {
- nixosConfigurations.clicks = let
- system = "x86_64-linux";
- pkgs = import nixpkgs {
- inherit system;
- config.allowUnfree = true;
+ nixosConfigurations.clicks =
+ let
+ system = "x86_64-linux";
+ pkgs = import nixpkgs {
+ inherit system;
+ config.allowUnfree = true;
+ };
+ in
+ nixpkgs.lib.nixosSystem {
+ inherit system pkgs;
+ modules = [
+ ./default/configuration.nix
+ ./default/hardware-configuration.nix
+ ./modules/mongodb.nix
+ ./modules/git.nix
+ ./modules/caddy.nix
+ ./modules/fuck.nix
+ ./modules/node.nix
+ {
+ security.sudo.wheelNeedsPassword = false;
+ users.mutableUsers = false;
+ }
+ ];
};
- in nixpkgs.lib.nixosSystem {
- inherit system pkgs;
- modules = [
- ./default/configuration.nix
- ./default/hardware-configuration.nix
- ./services/mongodb.nix
- {
- security.sudo.wheelNeedsPassword = false;
- users.mutableUsers = false;
- }
- ];
- };
deploy.nodes.clicks = {
profiles.system = {
@@ -33,5 +39,7 @@
hostname = "192.168.89.74";
profilesOrder = [ "system" ];
};
+
+ formatter.x86_64-linux = nixpkgs.legacyPackages.x86_64-linux.nixpkgs-fmt;
};
}