feat(silverbullet): init
Silverbullet is a browser-based markdown editor. We want a shared
notepad and have looked at various options (logseq, obsidian, Collabora
Online) but none of them have quite scratched the itch. That's not to
say they aren't great pieces of software - they are, and they have their
place, but they weren't quite what we needed.
We're hoping silverbullet can scratch that itch.
As a Clicks module, silverbullet uses *unstable* rather than your
default nixpkgs. This is because the version in nixpkgs was deemed too
far behind upstream - upstream is moving very fast right now, and we are
willing to trade off a potential bit of stability in exchange for newer
features. This may change in the future.
As per https://silverbullet.md/Authelia, we have exempted silverbullet
from Tailscale auth on some pages. For our instance on `teal` this makes
no difference - we don't have forwarding set up from the outside world
yet. In the future, this will change, and then it might matter a little
more. For anyone importing and using our modules on their own machines,
we hope that conforming to the authentication guide is welcome.
Change-Id: Ib22f45f0bcb0047e23233a06c7a26732fc3256f5
Reviewed-on: https://git.clicks.codes/c/Infra/NixFiles/+/816
Tested-by: Skyler Grey <minion@clicks.codes>
Reviewed-by: Samuel Shuert <coded@clicks.codes>
diff --git a/systems/x86_64-linux/teal/default.nix b/systems/x86_64-linux/teal/default.nix
index 4cceeca..9af45f5 100644
--- a/systems/x86_64-linux/teal/default.nix
+++ b/systems/x86_64-linux/teal/default.nix
@@ -231,6 +231,11 @@
};
domain = "fava.clicks.codes";
};
+ silverbullet = {
+ enable = true;
+ domain = "silverbullet.clicks.codes";
+ tailscaleAuth = true;
+ };
};
networking.tailscale = {