Add sliding sync proxy for matrix
Sliding sync is a future version of the matrix spec, but the proxy can be
deployed while still allowing us to use a non-proxied version. Sliding
sync allows much faster client load times, etc. as the client no longer
needs to sync everything
also: rip out commented/disabled coturn code
Change-Id: I9026ed7dcaec961f1bc54469f18f04b68f6e3918
Reviewed-on: https://git.clicks.codes/c/Clicks/NixFiles/+/82
Tested-by: Skyler Grey <minion@clicks.codes>
Reviewed-by: Maddie H <maddie@clicks.codes>
diff --git a/modules/common/nginx-routes.nix b/modules/common/nginx-routes.nix
index 8db7de7..865a171 100644
--- a/modules/common/nginx-routes.nix
+++ b/modules/common/nginx-routes.nix
@@ -69,8 +69,10 @@
]))
(Hosts ["matrix-backend.clicks.codes" "matrix-backend.coded.codes"] (Compose [
(Path "/_synapse/admin/" (Status 403))
- (ReverseProxy "127.0.0.1:4527")
+ (ReverseProxy "generic:1030")
]))
+ (Hosts ["matrix-sliding-sync.clicks.codes" "matrix-sliding-sync.coded.codes"]
+ (ReverseProxy "generic:1031"))
];
clicks.nginx.serviceAliases = with helpers.nginx; [
(Aliases "nextcloud.clicks.codes" [