feat: add postgres
We've made a postgres module which can create databases, users, etc. in
an ergonomic way
Change-Id: Ib574c96b5639797fac373a6384c450e98b25ea46
Reviewed-on: https://git.clicks.codes/c/Infra/NixFiles/+/727
Reviewed-by: Samuel Shuert <coded@clicks.codes>
Tested-by: Samuel Shuert <coded@clicks.codes>
diff --git a/lib/constants/default.nix b/lib/constants/default.nix
new file mode 100644
index 0000000..35e6034
--- /dev/null
+++ b/lib/constants/default.nix
@@ -0,0 +1,18 @@
+# SPDX-FileCopyrightText: 2024 Clicks Codes
+#
+# SPDX-License-Identifier: GPL-3.0-only
+
+{ lib, inputs, ... }:
+{
+ constants = {
+ hosts = {
+ standard = "127.0.0.1";
+ clicks = "127.0.0.2";
+ caramels = "127.0.0.3";
+ coded = "127.0.0.4";
+ minion = "127.0.0.5";
+ pinea = "127.0.0.6";
+ generic = "127.0.0.255";
+ };
+ };
+}